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A Pragmatic Manual for Getting Started with QRSTool:
Reducing EKG Data and Obtaining Many Metrics with CMetX

This overview will provide basic steps for importing EKG data to QRSTool, identifying interbeat intervals
(IBIs), correcting for instances where QRSTool misidentified beats, and finally exporting the IBI series and
calculate the metrics of cardiac variability using CMetX. More documentation for QRSTool is available in the
Help files within QRSTool.

Step 1: Import Data:
Option A: Neuroscan CNT File format.

1. Open QRSTool

2. File>Import=>.CNT File
a. File: Click on the ... to select the new file that has the EKG data
b. Select 16 bit (older) or 32 bit (more recent versions)
c. Select Import Events
d. If you have more than one channel, highlight the EKG channel
e. Select OK

3. QRSTool will load the EKG series into the bottom frame. You can zoom in and out using the

scroll when on your mouse (or scrolling portion of your laptop touchpad), or using the icon | on
the toolbar.

4. If you imported a Neuroscan file, you’ll notice there are blue numbers along the top of each window.
These are the codes that in the Neuroscan file if you used such to code which task was occurring
during the recording:

5. Often Neuroscan data has undocumented data of large magnitude at the end of the file. This
happens if you have marked segments of a file in Neuroscan Edit, and update the file; the marks
appear as ridiculously large data signals at the end of the file.

If so, the EKG series may appear as a flat line because the auto scaling will be biased by the large
amplitude “crud” at the end. If this is the case, will wish to place the cursor very close to the end of
the file, zoom in a bit so you can place the cursor close to the very obvious “crud”, and then right
click, crop, to end. You’ll now see the EKG series.

Before cropping the crud:
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6. If your data were recorded in DC mode, you may note the baseline drift over time, illustrated in the
figure as the series rises from left to right:
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7. We will wish to zoom in on a small section that will have relatively little drift. Use your scroll wheel

to zoom in and out, or from the toolbar, select the magnifying glass | .
a.  Use this tool to select a small region near the beginning of the EKG series by holding down
on the left button and pulling it across a portion of the screen.
b. Continue to zoom in by selecting a portion until you can see the EKG series clearly.

Option B: ASCII Text File format.
1. Open QRSTool
2. File>Import=> Text File
a. File: Click on the ... to select the new file that has the EKG data
3. Option 1: Importing a list of ECG Values only
a. ECG values only: Select this to import text files containing only ECG values.
b. Sample Period: The sampling period of the data. This is the inverse of the sampling rate
(frequency), equal to 1 / sampling rate.
Sample Rate: The sampling rate of the data. This is the inverse of the sampling period,
equal to 1 / sampling period.

mThis translates between rate and period. This button will only be enabled when one of
the two has been changed. Noze that some sampling rates and periods may not caleunlate correctly.
These values are typically those that cannot be divided with precision, typically factors of 10.
A number of sampling rates / petiods are calculated manually (e.g. 1000Hz and 0.001s
period will show correctly), however, it is always a good idea to check what the final sampling period will
be (since the imported data ultimately uses the sampling period).

4. Option 2: Importing ECG and Timestamps (two column data format)

a. ECG and Timestamp: Select this if each line of the text file contains both an ECG value,
and a timestamp value for that sample.

b. Timestamps in first column: Select if the timestamp precedes the ECG value on each line.
Timestamps in second column: Select if the timestamp follows the ECG value on each
line.

5. Overall Parameters:
New Series Name: The name of the newly imported series.

6. QRSTool will load the EKG series into the bottom frame.
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Step 3: Train the program how to find R-Waves
Before using an automated algorithm, we will first identify enough beats so that the program can estimate the
morphology of the EKG waveform surrounding a typical beat. We probably need about 30 seconds of data
to be marked using one of the two methods below.
1. Method 1 — amplitude threshold
a. Decide whether the positive or negative voltage spike is better differentiated from the rest of
the waveform. Typically we will find R spikes, but sometimes the S spike is easier to reliably
identify. In the sample waveform below, positive (up) or negative (down) would be fine, but
the negative spike (S wave) will prove easier to reliably identify than the positive spike (R
wave) in that it is unlikely to overlap with the later positive slower wave (T wave).
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c. Now choose the pointer i and highlight a short (ideally 30 second) region of the EKG
time series by left clicking and dragging. It will turn blue:
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& Now o - . o
. Now select the direction of beat detection: for positive or for negative (as in this
example).
e. Beats identified by the program appear as a red “hourglass”
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f. If your data are very clean, you may be able to use this threshold method and identify all
beats reliably. But for now, let’s assume you will just be using this method to teach
QRSTool the morphology of a typical beat for this subject, and you should proceed to Step
4 below.

2. Method 2 — Manually
a. Select the pointer on the toolbar
b. Make sure the following buttons are selected on the toolbar:

i. A crossed out heart » (overwrite existing beats)
ii. 'The button to the right of the crossed out heart: it is a blue box with a light blue arrow

pointing upwards. A (find positive peaks); to find negative peaks, choose the blue

box with a light blue arrow pointing down ¥

c.  While holding down the shift button, hold the left click button on the mouse, and highlight
an r-spike. The program will automatically find the apex of the R-wave and will place a red
hour glass on the top of the R-spike. Repeat this process on 30 R-spikes. If you selected the
down arrow, it will find the nadir of the S wave.

d. If you make a mistake, then you can “erase” a beat by holding Ctl-Shift-Left-click and drag
to highlight a small region around the beat. Any beats in the highlighted region will
disappear.

e.  You’ll notice as you add more hour glasses, a waveform appears in the upper window. The
distance between two R-spikes is called the Interbeat Interval (IBI). QRSTool plots
consecutive IBIs in the upper frame. We'll focus on this window in step #5.
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Step 4: Automate the process of finding the R-waves

1.

The peri-beat average algorithm helps to identify beats by using a prototypical EKG waveform
(based on the beats you identified in step 3) to filter the EKG series and identify r-spikes. This
corrects for drift, and also tends to be rather robust to other artifacts in the series. Before
proceeding, you should check that you did not miss any beats or identify any extra beats if you used
the threshold method above. You may need to remove any extra or insert any missed beats using the
tools described in Step 3 above.

Optional Check that the average waveform to be used by the peri-beat filter tool looks appropriate,
and to see what a prototypic waveform looks like. Select Tools=> Statistics=>IBI series. You'll see a
graph of the average EKG waveform with shaded areas representing the standard error. You may
wish to examine the length of the prototypic EKG waveform to use as parameters in the next step.
The example below on the left would indicate you’d done a good job of identifying beats, as the
standard error is small compared to the waveform, and the average waveform looks like EKG. By
contrast, the example on the right shows some problems with large standard errors near the R and S
peaks and the average waveform looks like a poor representation of EKG. In practice, the algorithm
described in the next step can tolerate some noise, but the cleaner you can make the waveform at this
step, the better.

Peri-beat average Peri-beat average

297.03 349.10

86.35 142.25

124,33 -64.55

-335.01 -271.37

-545.69 1 1 1 1 -478.19, | | I 1
-300.00 -150.00 0.00 150.00 300.00 -300.00 -150.00 0.00 150.00 300.00

Assuming you have a good sample of EKG waveforms, verified as described in the previous step,

»
you can now use the peri-beat filter tool: E . A window will appear allowing you to enter different

parameters for the peri-beat average algorithm. These values are initialized to those set in the
Tools=>Preferences=> Export window. The first two parameters (pre- and post-beat window length)
are likely to be the only ones that need to be changed; in general, these should range from 80 to
250ms. Longer times use more data points (centered on existing beats) to form the “prototype”
beat, however, long windows are also likely to capture variability due to changing IBI.

Select this button and QRSTool will use the prototype beat vector as a filter, convolving it with the
EKG series to create a new feature series. This filtering process corrects for drift will find the R-
spikes.

a.  QRSTool has now created a new series, called pb_filter.

b. Important. Return to the original series by going to the tool bar, find Series, and use the up
or down arrow to find the original series. Then click anywhere in the lower EKG waveform
window.

Optional: Check again that the average waveform now identified used by the peri-beat filter tool looks
appropriate; if it does not, then there may be problems with the IBI series. Then select
Tools=>Statistics>IBI seties. You’ll see a graph of the average EKG waveform. If this looks
peculiar, it may mean that the peri-beat function identified things other than the R-Spikes as beats
(e.g. high t-wave amplitudes).
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Step 5: Correct any errors the peri-beat filter created

1.

First, ensure that the peri-beat filter placed markers on the actual peak (or trough). You should be
working with the original series (not the pb_filter series). Looking at the original series in the lower
window (not the pbfilter series), examine to markers to determine if they are at the actual peak or
trough (depending on the direction your r-spike). The peribeat filter will often place the marker a
few samples to either side of the peak; this is because the convolution method with the prototypic
beat may shift the points by a tiny amount. To ensure that QRSTool places the markers at the peak,

use the lock beats tool to lock the beats to the nearest peak i or the nearest trough W Now
scan for artifacts as indicated below. It is usually a good idea to do this even if beats appear on the
peak, since this will ensure they are at the exact sample for the peak.
On the top window you will notice the IBI waveform is similar to the respiration waveform. Indeed,
the IBI series reflects the relationship of respiration to heart rate: when one inhales, heart rate
increases (and the distance between sequential R-spikes are shorter) and when one exhales, heart rate
decreases (and the distance between sequential R-spikes are longer)
The purpose of this task is to make sure the QRSTool did not mark another portion of the
waveform as an R-spike, or skip over an R-spike. You’ll need to zoom in again to be able to see the
waveform in more detail. Select the magnifying glass and zoom in to the beginning of the wave.
a. A file that requires no editing on your part would have an IBI series (top window) that
should look similar to respiration throughout the entire file (although this happens only if
you find all beats correctly, and don’t miss beats or misidentify erroneous beats):

R
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b. If QRSTool skipped over an R-spike, the IBI series would look similar to this (“stalagmite”):
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c. If QRSTool marked another part of the EKG series as an R-spike, the IBI series would look
like this (“stalactite”):
N\
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d. If you have several tasks in a file, and you paused your recording between them, you may see
stalagmites and stalactites between tasks where the stop/start point occurs. If you are going
to analyze data within task, but not across them (i.e., not using the data where the start/stop
code appears), you needn’t worry these stalagmites and stalactites because when we export
the data, we will be exporting data within each task and not the data between tasks. BUT, all
other stalactites and stalagmites are TROUBLE! (See Berntson & Stowell, 1998: ECG
artifacts and heatt period variability: don't miss a beat. Psychophysiology, 35, 127—132).
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Once you do so, the tool to put the beat midway between the selected beats
becomes available. Click this button, and now a beat is placed at the approximate time it
would have occurred in the absence of the ectopic beat (right panel below). Of course
this is not exactly where the beat would have occurred, but it is a reasonable estimate. It
creates two consecutive IBIs of identical length, and reduces variability, but it removes
variability due to the ectopic beat, which is a non-vagal source of variability but one that
can dramatically impact the metrics we used to infer vagal control. If there are not too
many beats like this, the data are usable, but we always code subjects with a YES/NO
variable indicating whether we corrected any such beats, so we can later analyze data
with and without these subjects to assess the impact of this approach.

Latest Revision 8/2/2011

To fix a missed or extra beat, zoom in (scroll wheel) on that portion of the waveform, and
then you can use Ctl-Shift-Click and drag to remove beats from a highlighted region, and use
Shift-Click and drag to insert a beat at the maximum in point in a highlighted region.

Repeat as needed until all artifacts are removed.

Dealing with ectopic beats. Ectopic beats occur outside the predictable rhythm of the ongoing
EKG. You can exclude all subjects with ectopic beats, which would be the most conservative
approach. Butitis also the case that sometimes an ectopic beat does not reset the ongoing rhythm
beyond the time frame of the ectopic beat, in which case you could estimate where the beat should
have occurred and use the subject (see section a below), but in other instance, the ongoing rhythm is
reset, in which case the data are not usable (see section b below). In all cases, our standard laboratory
procedure is to contact the research participant to suggest they check with their physician.

Ectopic beats that can be possibly used. The situation below on the left shows where the
first beat within the encircled area occurred a bit sooner than might have been expected, and
the subsequent beat was delayed relative to this early beat, but about on time given the
overall series of beats.. You can actually see it in the EKG in the lower part of the figure.
The timing of the two beats together (the early beat plus the late beat), however, is the same
So a solution is to remove the eatly beat, and place a
beat midway between the beat that preceded it and the one that followed it.

First, remove the early beat using Ctl-Shift-Left-Click and drag in the lower window
across the beat.
Now, highlight the region from the beat before to the beat following where the early
beat occurred (middle panel below).
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b. Ectopic beats that spell TROUBLE for RSA. These ectopic beats reset the ongoing rhythm
of the EKG, and thus will introduce non-vagal variability that cannot be corrected. These
beats also often have an unusual morphology in the EKG like that below. Notice that when
the same steps listed above are implemented (remove eatly beat, then place beat midway
between adjacent beats), that the ongoing IBI series is still distorted (red circle below).
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Step 6: Make sure all of the event markers appear
1. Event codes can be used to delineate segments of the file for analysis. If you have event markers to
delimit the beginning and end of a segment (or task) you don’t need to do more at this time — skip to
step 7. Also, if your EKG file begins with the start of the task or segment, and ends with the end of
the task or segment (i.e. not non-task data), you will not need event codes and can skip to step 7.

If you have a file with some non-task data, or a file with multiple tasks, you need event codes. If you
did not have such event codes, you’ll need to insert them as detailed in the next step. If your file is a
single task, but begins after the beginning of the file or ends before the end of the file, then all you
need to have is a marker at the beginning and another at the end of the task. If you have multiple
tasks in the file, then you need to have pairs of markers, each pair delineating the start and end of a
segment. The marker at the beginning and end of the segment should be the same number. These
markers will delineate what portions CMetX will provide summary statistics for (see step 7).

2. Select the Keymap Editor . button on the toolbar
a. Place the cursor in the Key field
i Select the function key F2 on the top of the keyboard (many keys can be used, but
F1 brings up help; you could use the number keys numbers as well).
b. Place the cursor in the Value field
i. Select a code for a given task/segment (e.g resting baseline might be 1, stress task
might be 2, etc.);
c. Click Add/Change, OK
d.  Go to the part of the EKG series where a code is needed.
i. Select the cursor button
ii. Left click right on top of the event codes that are already there and press F2 (or
whatever key you defined).
1. You should see the event number appear in blue
e. Go to the part of the EKG series that the other set of markers should be
i. Select the cursor button
. Left click on the series and press F2 (or appropriate key).
1. You should see the event number appear in blue
f.  Repeat as needed to insert all necessary events.
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Step 7: Running CMetX (this program calculates common heart rate metrics, including RSA)
1. Make sure QRSTool knows where CMET lives
a.  Go to Tools>Preferences=> Export
b. CMET Path will typically be
C:\Program Files\QRSTool\CMet\CMetX.cxe
c. OK
2. Ifyour file does not need event codes, because the entire file is task data, then run CMetX on
the entire file. But if you have event codes, then skip to one of the next two options. To
export then entire file and run CMetX'

a.  Select File, Export CMetX ( " button on the toolbar).
i.  The options “Run CMET on exported IBI series: and the option “Export All” should
be enabled
ii.  Under Export file, press the “
ili. Find the folder where you’d like to save this output and type in a file name for the
output (e.g. “FILENAME_ibi)
b. Several new files will appear in this folder.
3. Event Codes Option 1 — Running CMetX Manually from Menus
a. Select a range of events for CMetX to analyze:

i. Events>Edit Events €
. Check “Select using events”

ili. Change “variables” to StimType

iv. If you have a section that has the same code that identifies the beginning and end of
a section (e.g. “1” at the start of the resting baseline and “1” again at the end), or a
section that has the same code repeating throughout it (e.g. “1” repeats every second
during the resting baseline), then choose “First to Last” and select the code of
interest.

v. If you have different codes for beginning and end, then use the “between events”
option to select the starting code and ending code.

vi. Determine whether you wish to compensate for the loss of data in CMetX due to
the filter. When CMetX filters the data to pass the respiratory frequency range, the
first 12 seconds and the last 12 seconds of data are lost to the filter. QRSTool
offers an option to avoid this problem if you have EKG data collected before and
after your segment of interest. If you wish to fully compensate for the CMetX
filter-related data loss, then change the values under “Time Window” to indicate 12
seconds before and 12 seconds after.

vii. Click OK

b. Now export the IBI series and run CMetX

i. File>Export CMetX ( " button on the toolbar).

ii. Other options should be correctly set (“Selection” and “Unlock after write”)

iii. Check the filename and change if you wish. This is the name of the file that will
contain the IBI series for this segment of data (e.g. the IBI series for resting
baseline). It will have your filename followed by the number of the code(s) used to
identify this segment.

iv. Click Export — three files are created (or appended): your IBI file,
HRVMETRC.CSV (file with CMetX output) and HRVMETRC.LOG (CMetX
logging of unusual IBI sequences to check for possible error in IBI identification).

4. Event Codes Option 2 — Using Scripting Macros
a. Full information is available from the Help Files in QRSTool, but below is a script that will work
for files with Neuroscan codes. Comments about this script:
i Scripts commands should be saved as an ASCII text files with a TXT extension
ii. This script expects to find Neuroscan Stimulus codes
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ili. This data file has eight segments, each of which has a code repeating during a segment.
You’d need at the very least, a code to demark the start and another to demark the end of a
segment for analysis.

iv. The event select selects neuroscan codes, and also “pads” the file with 12 seconds before and
after the codes, as CMetX will not analyze the first and last 12 seconds of data due to the
filter.

v. For the first 7 segments, the data segment will include 12 seconds before and after the codes,
and if the file would not permit this (e.g. not enough data precedes or follows the segment),
the data segment would not be clipped — and it would not be analyzed. For the 8* segment,
however, 12 seconds before and after the codes are to be included, unless there is insufficient
data, in which case the data are clipped to the available data length, padding with what is
available.

Sample Script File (note that no lines should wrap in your text editor)

START _LOG <C:\Users\You\Data\GreatProject\ log cmet.txts>

CMET_PATH <C:\Program Files\University of Arizona Psychophysiology
Laboratory\QRSTool and CMetX\cmet\CMETX.EXE>

SET_OUTPUT DIRECTORY <C:\Users\You\Data\GreatProject>

CMET_PARAM DEFAULT IBI_PATH <C:\Users\You\Data\GreatProjects>

CMET_ PARAM OUTPUT <C:\Users\You\Data\GreatProject>

EVENT_SELECT FIRST TO LAST <cnt2> <StimType> 1 12.0 12.0 NO_CLIP NO_STOP
EXPORT CMET SELECT <> <>

EVENT_SELECT FIRST TO LAST <cnt2> <StimType> 2 12.0 12.0 NO_CLIP NO_STOP
EXPORT CMET SELECT <> <>

EVENT_SELECT FIRST TO LAST <cnt2> <StimType> 3 12.0 12.0 NO_CLIP NO_STOP
EXPORT CMET SELECT <> <>

EVENT_SELECT FIRST TO LAST <cnt2> <StimType> 4 12.0 12.0 NO_CLIP NO_STOP
EXPORT CMET SELECT <> <>

EVENT_SELECT FIRST TO LAST <cnt2> <StimType> 5 12.0 12.0 NO_CLIP NO_STOP
EXPORT CMET SELECT <> <>

EVENT_SELECT FIRST TO LAST <cnt2> <StimType> 6 12.0 12.0 NO_CLIP NO_STOP
EXPORT CMET SELECT <> <>

EVENT_SELECT FIRST TO LAST <cnt2> <StimType> 7 12.0 12.0 NO_CLIP NO_STOP
EXPORT CMET SELECT <> <>

EVENT_SELECT FIRST TO LAST <cnt2> <StimType> 8 12.0 12.0 CLIP NO_STOP
EXPORT CMET SELECT <> <>

RESET_SKIP

END_LOG

b. .If you had to add event markers, you’ll need to edit this sctipt to look for internal codes, like the
following line — to look for a segment you demarcated with a keyboard code “1”:

EVENT SELECT FIRST TO LAST <internals> <internals> 1 12.0 12.0 NO_CLIP NO_STOP

c. Now — run the scriptl On toolbar find “Script”, and click on the button with “...”. Select: your
script (note that scripts are ASCII files with a TXT extension)
Select “Run”

e. QRSTool will export IBI series and run CMET

f.  Several new files will appear in your specified directory (txt files with IBI, and a csv file with your
metrics).

g. As an alternative, you can simply export the IBI files without running CMetX at this time, and
then run CMetX from the command prompt later. By typing CMetX /? in a command window,
instructions on command line parameters will be provided. 1f you have any familiarity with
windows CMD files, you could write a file that repeated calls CMetX to run on each IBI file,
with the parameters you choose. A sample script below shows how you can simply export the
IBI files:
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Sample Export IBI Script File

SET OUTPUT DIRECTORY <C:\Users\You\Data\GreatProjects>
CMET_PARAM DEFAULT IBI_ PATH <C:\Users\You\Data\GreatProjects>

EVENT SELECT FIRST TO LAST <cnt2> <StimType> 1 0.0 0.0 NO_CLIP NO_STOP
EXPORT TBTI SELECT <>

EVENT SELECT FIRST TO LAST <cnt2> <StimType> 2 0.0 0.0 NO CLIP NO_STOP
EXPORT TBTI SELECT <>

EVENT SELECT FIRST TO LAST <cnt2> <StimType> 3 0.0 0.0 NO CLIP NO_STOP
EXPORT TBTI SELECT <>

EVENT SELECT FIRST TO LAST <cnt2> <StimType> 4 0.0 0.0 NO CLIP NO_STOP
EXPORT TBI SELECT <>

EVENT SELECT FIRST TO LAST <cnt2> <StimType> 5 0.0 0.0 NO CLIP NO_STOP
EXPORT TBI SELECT <>

EVENT SELECT FIRST TO LAST <cnt2> <StimType> 6 0.0 0.0 NO CLIP NO_STOP
EXPORT TBI SELECT <>

EVENT SELECT FIRST TO LAST <cnt2> <StimType> 7 0.0 0.0 NO CLIP NO_STOP
EXPORT TBI SELECT <>

EVENT SELECT FIRST TO LAST <cnt2> <StimType> 8 0.0 0.0 NO CLIP NO_STOP
EXPORT TBI SELECT <>

RESET_SKIP

END_LOG

5. Running CMetX from the command line
If you exported files as described above from QRSTool, or if you have IBI files from another source,
CMetX can be run on the command line by opening a command window. During the installation
program, a path to the location of CMetX was created, so you can run CMetX from any directory. It
might be handy to change directories to the directory where your IBI files reside. And if you are
using Windows 7, you can simply shift-right-click on the directory in the file explorer, and choose
“Open command window here” to have a command window with your IBI file directory as the
default directory. Below are the parameters you can use with CmetX (which are also available by
typing CMetX /? at the command line).

Usage: CMetX IBI File [-o OutputFile] [-f FilterChoice]
[-c CoefFile] [-d lowcut highcut] [-a ArtThreshold] [-i]
IBI File Required: Name of the input file
with IBIs in msec (no extension)
-- program assumes ".TXT" extension
-o OutputFile Optional: Name the output file

(no extension no spaces unless quotes)
-- output file will have ".CSV" extension
-- Default is HRVMETRC

-f FilterChoice Optional: Select one of the included filters
to define respiratory frequency band. Choices include:
- 012 040 = .12 to .40 Hz (Default, like MXEdit)
- 015 040 = .15 to .40 Hz (Alternate Adult)
- 024 104 = .25 to 1.04 Hz (Infant)
- 030 130 = .30 to 1.30 Hz (Newborn)

- UserCoef = use user-provided filter (requires -c)
- Design = design custom filter with CMetX (requires -d)

-c CoefFile Optional: Filter filename (requires -f UserCoef)
-d lowcut highcut Optional: Filter filename (requires -f Design)
-- example: -d 0.10 0.50 creates .10 to .50 filter
-a ArtThreshold Optional: specifies the difference between
successive IBIs that is considered to be an
artifact. This does not change the calculations,

but simply places a warning in the log file.
-- Default is 300 msec
-i Optional: Output interpolated time series (.DAT)
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Other suggestions:

1. Be sure to check the help file of QRSTool and also examine the included sample scripts usually
installed under C:\Program Files\QRSTool\scripts.

2. Ina CMD window (Start, run, CMD), type CMetX with no parameters to receive more information
about CMetX and its metrics

3. Consider running QRSTool to the point of obtaining artifact free IBI series and then save the results
as a native QRS file. The later use scripting to open the file and export the relevant sections to
CMetX.

4. Check out the following paper for more details about the metrics and recording considerations:
Allen, J.J.B., Chambers, A.S., & Towers, D.N. (2007). The many metrics of cardiac chronotropy: A

pragmatic primer and a brief comparison of metrics. Biological Psychology, 74, 243—262.

Page 12



